]> git.pld-linux.org Git - packages/libsigc++12.git/blame - libsigc++12.spec
- unconditional noarch subpackages
[packages/libsigc++12.git] / libsigc++12.spec
CommitLineData
e2fff4cc
JB
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4
bb864b42 5Summary: The Typesafe Signal Framework for C++
3fb2ce85 6Summary(pl.UTF-8): Środowisko sygnałów z kontrolą typów dla C++
bb864b42 7Name: libsigc++12
a5883d99 8Version: 1.2.7
e2fff4cc
JB
9Release: 4
10License: LGPL v2+
bb864b42 11Group: Libraries
e2fff4cc 12Source0: https://download.gnome.org/sources/libsigc++/1.2/libsigc++-%{version}.tar.bz2
a5883d99 13# Source0-md5: 212f48536019e1f003d2509b4c9b36df
bb864b42 14Patch0: %{name}-m4.patch
5c65ed3e 15Patch1: am-lt.patch
e2fff4cc 16URL: https://libsigcplusplus.github.io/libsigcplusplus/
bb864b42 17BuildRequires: autoconf
18BuildRequires: automake
19BuildRequires: libstdc++-devel
e2fff4cc 20BuildRequires: libtool >= 2:1.5
bb864b42 21BuildRequires: m4
e2fff4cc
JB
22BuildRequires: rpmbuild(macros) >= 1.752
23%if %{with apidocs}
24BuildRequires: docbook-dtd412-xml
25BuildRequires: docbook-style-xsl-nons
26BuildRequires: libxslt-progs
27%endif
bb864b42 28Obsoletes: libsigc++-examples
ce065e51 29Obsoletes: libsigc++ < 1:1.9
82de8cea 30Conflicts: libsigc++ < 1.1.0
bb864b42 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This library implements a full callback system for use in widget
35libraries, abstract interfaces, and general programming. Originally
82de8cea 36part of the Gtk-- widget set, libsigc++ is now a seperate library to
bb864b42 37provide for more general use. It is the most complete library of its
38kind with the ablity to connect an abstract callback to a class
39method, function, or function object. It contains adaptor classes for
40connection of dissimilar callbacks and has an ease of use unmatched by
41other C++ callback libraries.
42
4b1c2a0e
JR
43%description -l pl.UTF-8
44Ta biblioteka jest implementacją pełnego systemu callbacków do
45używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
46ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
47Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
48przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
49łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
50obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
51callbacków.
bb864b42 52
53%package devel
54Summary: Development tools for the Typesafe Signal Framework for C++
3fb2ce85 55Summary(pl.UTF-8): Narzędzia programistyczne do środowiska libsig++
bb864b42 56Group: Development/Libraries
bb864b42 57Requires: %{name} = %{version}-%{release}
eb3c597c 58Requires: libstdc++-devel
59Requires: m4
ce065e51 60Obsoletes: libsigc++-devel < 1:1.9
bb864b42 61
62%description devel
63Development tools for the Typesafe Signal Framework for C++.
64
4b1c2a0e
JR
65%description devel -l pl.UTF-8
66Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
67kontrolą typów.
bb864b42 68
69%package static
70Summary: Static Typesafe Signal Framework for C++ libraries
3fb2ce85 71Summary(pl.UTF-8): Statyczna biblioteka libsigc++
bb864b42 72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
ce065e51 74Obsoletes: libsigc++-static < 1:1.9
bb864b42 75
76%description static
77Static Typesafe Signal Framework for C++ libraries.
78
4b1c2a0e
JR
79%description static -l pl.UTF-8
80Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
bb864b42 81
e2fff4cc
JB
82%package apidocs
83Summary: API documentation for libsigc++ 1.2.x
84Summary(pl.UTF-8): Dokumentacja API do libsigc++ 1.2.x
85Group: Documentation
1e2dd847 86BuildArch: noarch
e2fff4cc
JB
87
88%description apidocs
89API documentation for libsigc++ 1.2.x.
90
91%description apidocs -l pl.UTF-8
92Dokumentacja API do libsigc++ 1.2.x.
93
bb864b42 94%prep
95%setup -q -n libsigc++-%{version}
96%patch0 -p1
5c65ed3e 97%patch1 -p1
bb864b42 98
99%build
100CXXFLAGS="%{rpmcflags} -fno-exceptions"
bb864b42 101%{__libtoolize}
e2fff4cc 102%{__aclocal} -I scripts
bb864b42 103%{__autoconf}
104%{__automake}
105%configure
106%{__make}
107
e2fff4cc
JB
108%if %{with apidocs}
109%{__make} -C doc/manual
110%endif
111
bb864b42 112%install
113rm -rf $RPM_BUILD_ROOT
114
5c65ed3e 115%{__make} -j1 install \
bb864b42 116 DESTDIR=$RPM_BUILD_ROOT
117
e2fff4cc
JB
118# obsoleted by pkg-config
119%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsigc-1.2.la
120
bb864b42 121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
e2fff4cc 129%doc AUTHORS ChangeLog FEATURES IDEAS NEWS README TODO
decf48e1 130%attr(755,root,root) %{_libdir}/libsigc-1.2.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/libsigc-1.2.so.5
bb864b42 132
133%files devel
134%defattr(644,root,root,755)
decf48e1 135%attr(755,root,root) %{_libdir}/libsigc-1.2.so
decf48e1 136%{_includedir}/sigc++-1.2
137%{_libdir}/sigc++-1.2
138%{_pkgconfigdir}/sigc++-1.2.pc
bb864b42 139
140%files static
141%defattr(644,root,root,755)
decf48e1 142%{_libdir}/libsigc-1.2.a
e2fff4cc
JB
143
144%if %{with apidocs}
145%files apidocs
146%defattr(644,root,root,755)
147%doc doc/{API,FAQ,UML,conventions,diagrams,marshal,powerusers,requirements,signals} doc/manual/html
148%endif
This page took 0.107152 seconds and 4 git commands to generate.